Microsoft Teams Notifications Failing to Deliver

Incident Report for Centro

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 14:15 MDT

Monitoring

The Microsoft API seems to be back up - we're continuing to monitor and check status of the application.
Posted Mar 24, 2026 - 13:25 MDT

Investigating

For Microsoft Teams customers, Notifications from Salesforce to Teams will fail to deliver. There seems to be an underlying Microsoft API incident.
Posted Mar 24, 2026 - 12:44 MDT
This incident affected: Centro for Microsoft Teams.